The issue has been mitigated, and impacted services have been restored. We are continuing to monitor the service closely and do not currently anticipate any further impact.
We apologize for any inconvenience caused and appreciate your patience and understanding.
If you have any questions or require further assistance, please contact the API Service Desk, and our team will be happy to help.
Posted Jul 22, 2026 - 16:58 UTC
Update
Our technical teams have successfully mitigated the issue, and services have been restored and are operating normally. We continue to monitor the environment closely and are progressing work towards a permanent resolution.
We apologise for any inconvenience this incident may have caused and thank you for your patience and understanding.
If you have any questions or require further assistance, please contact the API Service Desk, where our team will be happy to help.
Posted Jul 22, 2026 - 12:19 UTC
Update
We are continuing to investigate this issue.
Posted Jul 22, 2026 - 11:06 UTC
Investigating
We are currently experiencing an incident impacting our APIs for NatWest, Royal Bank of Scotland, Ulster Bank (Northern Ireland).
Our technical teams are actively investigating and working to resolve the issue as quickly as possible.
We apologize for any inconvenience and appreciate your patience while we restore normal service.
Should you have any concerns or need support, get in touch via our API Service Desk. We’ll be on hand to help.
Posted Jul 22, 2026 - 11:06 UTC
This incident affects: NatWest Bank - Accounts API (NWB - Accounts API - CreditCard), Royal Bank of Scotland - Accounts API (RBS - Accounts API - CreditCard), and Ulster Bank NI - Accounts API (UBN - Accounts API - CreditCard).